oldfab

il sito di Fabrizio Oldrini

PPA1200 - Poor Portable Amiga 1200

caratteristiche:

-scheda madre A1200 Amiga Technologies rev. 1.D.4 (oppure A1200 Commodore rev 1.A)

-scheda acceleratrice Phase5 BlizzardPPC 68040/25MHz - 603e/175MHz - ram 256MB

-scheda grafica DCE BlizzardVision (BVision)

-HD IDE 2.5" 10GB

-DVD R/W Dual Layer slim Samsung

-Floppy drive 880KB Amiga

-scheda di rete PCMCIA 3COM 10Mbit, Wi-Fi con access point in modalità client

-PSU 150W

-tastiera Amiga 500 con adattatore autocostruito

-display 16:9 ASUS LCD VW161D

-AOS4.1FE

siccome avevo questa scheda A1200 rev 2, che mi girava per il laboratorio, e non avevo il guscio, ho deciso, per evitare cortocircuiti durante le prove, di inserire detta scheda in una valigetta porta attrezzi, sapete, quelle belline di legno ricoperto di plastica che sembra metallo. Poi m'è venuto in mente il nome, Amiga Portatile Povero, perchè per ora non ho speso nulla (a parte gli adattatori CF2IDE e SD2CF).
Ecco le foto:
il progetto aperto e in funzione:
da sinistra, cdrom slim 24x, schermo PSone, floppy Amiga 100% compatibile (vorrei metterci un floppy slim ma per ora non sono riuscito a interfacciarlo correttamente). Tra il display e il floppy si nota la schedina LED dell'A1200. La tastiera è una di prova, infatti manca un tasto.

l'alimentatore, recuperato da un server di stampa Fiery X2, che ha i voltaggi giusti per l'A1200, +12, -12 e +5 volt.
I 7.5 volt per il display LCD Sony li estrae dai 12volt quell'integrato che si vede a sinistra sul radiatore, è un 7808, che quindi eroga 8 volt, ma sembra che l'LCD non abbia problemi per gli 0,5 volt in più. Siccome l'LCD ciuccia 600mA e l'integrato è da 1A, scalda non poco, per questo ho messo il radiatore.


il display LCD Sony PSone che mostra il Workbench 3.1 in RGB PAL. Per sapere come interfacciare questo display ad un Amiga, visita la sua pagina in questo sito.



una SD da 1 GB inserita nell'adattatore SD2CF che è inserito nell'adattatore CF2IDE, alimentato direttamente dal cavo IDE 44pin, ma appena possibile, metterò una CF da qualche GB, perchè la SD con adattatore fa il boot solo dopo un reset. deve essere un problema di non totale trasparenza dell'adattatore SD2CF. si vede l'header per la tastiera A500, infilato nel connettore della tastiera. foto più dettagliate della modifica sono in un'altra pagina del sito. qui non si vede l'adattatore IDE da 44 a 40pin e il cavo per connettere il cdrom slim perchè al tempo della foto non l'avevo ancora montato, ma è lo stesso sistema che usavo sull'altro A1200.

aggiornamento del 2-08-2009

Sto cercando un diverso tipo di case, la valigia non mi soddisfa e è troppo ingombrabte. Cerco qualche scatola metallica in cui mettere scheda madre, acceleratrice, scheda video, cdrom slim e floppy, che abbia il minimo ingombro. Come tastiera intendo usare quella di un A2000 debitamente interfacciata. In pratica vorrei un desktop di ingombro minimo. 

Ho acquistato una Phase5 BlizzardPPC con 160MB di ram (128+32); è una 68040/25 e 603/175.
Dalla stessa persona ho comprato una DCE BVision, che ho montato sulla BPPC.
Ho tolto il monitor LCD Sony perchè è troppo piccolo e con la BVision, mi collego ora ad un monitor LCD BeLinea da 17"
Floppy e cdrom slim sono gli stessi, anche se ora sono volanti perchè non ho ancora deciso la posizione.
Ho installato l'OS4.0.
Ecco le foto più recenti e, di seguito, la precedente versione.

Vista generale


Spostata la tastiera, si vede l'HD da 4GB sopra ad un cuscinetto di plastica antistatica isolante, la BPPC con i suoi 160MB di ram e la BVision, il connettore VGA della BVision fissato sul retro della valigetta, l'alimentatore prelevato da un vecchio HP Vectra.
La busta CD che c'è sotto la BVision ha il duplice scopo di isolarla e renderla più visibile in foto :)

La scheda di rete, è sempre la stessa PCMCIA 3COM Megahertz che usavo con l'altro A1200, un po' di problemi per farla utilizzare dall'OS4.0. Il driver utilizzato è sempre il 3c589.device che c'è su Aminet, ma invece che usare i programmi nel cassetto sys:internet, oppure il programma internet che c'è in prefs, ho creato una interfaccia manualmente, e così funziona. se volete maggiori dettagli, scrivetemi che ve li mando.


la pagina di apertura dell'OS4.0 sul monitor LCD da 17" e il progetto aperto di sotto


www.amiga.org aperto con OWB

aggiornamento del 30-11-2009

Ho acquistato un monitor ASUS LCD VW161D e l'ho inserito nel coperchio della valigia.
Ho tagliato il coperchio seguendo la sagoma posteriore del monitor, che ho montato in modo che, a coperchio chiuso, non tocchi la tastiera. Il profilato d'alluminio forato che fissa il monitor in alto, in realtà è un pezzo di spigolo per edilizia, non avevo di meglio in casa!
Questo monitor raggiunge la risoluzione 1366x768@60Hz, che ho settato nei tooltypes del driver della BVision.
Ma siccome con quella risoluzione le icone sono un po' piccole e io ci vedo poco, ho preferito optare per una 1024x600@60Hz.
La BVision le regge tuttedue :)
Floppy e cdrom sono ora volanti, prima o poi li fisserò a dovere.
Ecco le foto







Aggiornamento del 23 agosto 2010

Questo potrebbe essere l'aggiornamento conclusivo. In questi giorni di ozio estivo mi sono dato da fare nel sistemare tutti i pezzi del PPA1200 che erano vaganti:

-montate 3 barre di rinforzo alla valigia (provenienti da un letto IKEA)

-inserito cdrom (dvd r/w) e floppy nella valigia, aprendo delle apposite feritoie nel lato SX

-alzato il castelletto del connettore per la tastiera A500

-montato l'HD da 4GB nella sua staffa originale e quest'ultima fissata ad una delle barre di rinforzo

-saldato il cavo di alimentazione del display in parallelo al cavo di alimentazione comandato dall'interruttore principale

-fissata la schedina dei LED ad una delle barre

-aperta una presa d'aria con griglia nel fondo della valigia, in corrispondenza della ventola del 68040

-sostituita la ventola 12V del 68040 con una da 5V, più sottile, collegata in parallelo a quella del 603e

-montata una ventola 5V sul chip Permedia2 della BVision

per quanto riguarda il sistema operativo, sono tornato al vecchio OS3.9, al quale però ho aggiunto, oltre ai canonici BB1 e BB2, anche il BB3 e il BB4, che ho trovato in rete, frutto del lavoro di amighisti appassionati.

Attualmente non riesco più ad installare il 4.0, l'installazione si ferma sempre poco dopo che è caricata la rom aggiornata, mi appare lo schermo Workbench ma poi, o va in GURU, oppure si freeza, e non c'è verso di andare avanti. Succede così sia che parta da floppy o da cdrom.

Un mesetto fa ho tentato l'installazione di MorphOS 1.4.5 nella versione gratuita che si scarica da Internet. Ci sono riuscito e devo dire che l'effetto è notevole, ma poi, quando ho tentato di aggiornarlo, anche perchè così com'è non ha nulla dentro, dopo l'aggiornamento mi si blocca sempre.

Ecco le ultime foto, in fondo anche qualcuna del tentativo con MOS (MorphOS).

 

 

Aggiornamento dell'8 marzo 2015

Aggiornato il sistema operativo. Siccome la Hyperion Entertainment alla fine de 2014 ha fatto uscire una nuova versione del sistema operativo, Amiga OS4.1FE, finalmente ad un prezzo abbordabile, ho deciso di comprare da Vesalia.de 2 versioni, una per gli Amiga classici e l'altra per gli AmigaOne (basati su schede Eyetech). Totale per le due versioni con spedizione, 66,81 euro, arrivati 4 o 5 giorni fa.

Una battaglia, l'installazione, ma solo perchè nelle scarne istruzioni cartacee non hanno scritto 'PRIMA DI INSTALLARE LEGGERE LE FAQ SUL CDROM', dove sono spiegate tutte le problematiche che possono verificarsi con gli Amiga classici, e vi assicuro che ce ne sono. Così avrei evitato un sacco di tempo perso, patemi e male agli occhi...

Ho comunque eliminato le altre installazioni sull'HD, il 4.0 e MorphOS, MorphOS era inusabile, e il 4.0 era limitato, anche se rimpiango che sul 4.1FE manchino le scorciatoie da tastiera nei menu Finestre e Icone :(  

Comunque, ecco qualche foto

 

lo splash screen del 4.1FE, durante il quale viene caricato il kickstart

 

schermata dell'installazione da floppy/cdrom; oltre al cd è fornito un floppy per chi voglia fare l'installaziione su un hd vuoto. oppure si può installare partendo da 3.9/4.0/4.1.6, ma bisogna comunque installare su una partizione vuota, non è previsto l'aggionamento da precedenti versioni 

 

 

l'errore che mi ha fatto impazzire. dopo l'installazione, avvenuta senza alcun problema, al cold reboot appariva questa schermata. è tutto spiegato nel documento Classic_FAQ.pdf che è nel CD, ma non hanno spiegato che è meglio leggerlo prima di installare....