oldfab

il sito di Fabrizio Oldrini

Che scheda madre è?


aggiornamento del 03/04/2008

ecco qui un'altro bel caso da risolvere.
Un mio amico, Roberto, tempo fa mi ha dato questa interessante scheda madre per Pentium 3, deve essere una scheda industriale o embedded, date le caratteristiche.
Sto cercando chi l'ha prodotta, per tentare di avere il manuale. La sigla è AW-MB600 REV.A3, il produttore potrebbe essere www.aewin.com.tw ma non si sono ancora degnati di rispondermi :(
Come vedete è molto interessante, avendo un connettore IDE0 a 44 pin, un connettore IDE1 per schede CF, uno slot Mini-PCI, 2 uscite video VGA, chip video ATi Radeon 215R6LAEA12 con 32MB di video ram on board, chipset VIA CLE266, RJ45, Firewire, 2USB+ 2, parallela, seriale, IR.
Il bios è un Phoenix e la stringa del bios è la seguente:
07/29/2004-CLE266-8235-6A6LUBG9C-B1
Mouse e tastiera stanno su un solo connettore con 9pin, quindi non so quali sono i pin specifici.
Sono riuscito a farla funzinare estrapolando che fosse alimentata da una sola tensione, 5Volt DC, e avevo ragione, in quanto la scheda fa il boot, ma, ovviamente, siccome non ho la tastiera, non riesco ad andare oltre allo schermo di POST.
Al boot appare il logo che vedete anche serigrafato sul retro della scheda
Avendole connesso un HD da 2.5" sul IDE0 e una CF sul IDE1, sono stati entrambi riconosciuti


ecco il logo su schermo e su scheda

per quanto riguarda i due header da 40 pin sulla sinistra, che sembrano IDE, ci ho collegato, a quello in alto nella foto, un cdrom slim, alimentato dall'alimentatore ATX che ho usato per la prova.
Risultato, puzza di Brucio! ed è saltato l'UPS che stava a monte!
Quindi, non sono IDE, probabilmente sono connettori di un BUS proprietario oppure header per un BUS PCI.
Se avete notizie o mi date qualche dritta per risolvere il dilemma...
l'email la conoscete, è scritta da qualche altra parte nel sito :)
grazie


 

aggiornamento del 14-12-2008

non è che mi occupi spesso di questa scheda, comunque ora funziona con WinXP Pro SP2 su un HD 2.5", da 10GB.

Una cosa interessante è che l'uscita video ufficiale è la Radeon, e sull'altra, quella servita dal chip VIA, prosegue il desktop a destra del desktop Radeon. Inoltre, nelle proprietà del video, sono presentati 3 schermi, il Radeon, il CLE266 e un terzo che però sulla scheda non ha uscita, boh?!

Per quanto riguarda il funzionamento, ho avuto qualche problema col mouse PS/2, che a volte non è riconosciuto, cioè non funziona. Comunque, quelle volte, utilizzo un mouse USB e risolvo.

Per collegarci un CDROM ho ragionato a lungo sulla disposizione dei pin dell'header 44pin IDE e sulle varie possibilità che avevo, e alla fine ho deciso di saldare una doppia serie di pin passo 1mm sul retro della scheda madre, in pratica i pin li ho saldati dove ci sono le saldature dei pin della femmina 44pin che c'è nell'altro lato della scheda, creando quindi un maschio 44pin. Poi ho connesso un adattatore da 44 a 40pin e ho collegato il cdrom, viene tranquillamente visto.

Potrei utilizzare anche il connettore per Compact Flash e installarci WinXP lì su una CF, ne ho varie e fare il boot da CF, ma ho notato su altre schede madri, che le CF sono comunque più lente degli HD, e quindi non conviene. Evidentemente questa possibilità della CF è perchè una volta che le schede industriali sono accese, non devono caricare vari programmi etc, come in un normale uso di WinXP, ma caricano solo un programma e quello usano, per cui la velocità di accesso alla CF non importa. 

Altra cosa che ho scoperto, è che questa scheda ha un formato tutto suo, non è standard, infatti i fori di fissaggio non coincidono con quelli delle schede ATX e derivate. Il formato della scheda è 21cm x 19cm, e si avvicina al FlexATX, ma è più piccola di circa 1cm per lato.

aggiornamento del 14/04/2008
sono riuscito a collegare tastiera e mouse PS/2, al connettore a 10 pin IDC (il pin 5 manca), con questo pinout:
pin 9 e 10 +5volt
pin 7 e 8 ground
pin 6 non collegato
pin 5 mancante (è il pin chiave)
pin 4 mouse clock
pin 3 keyboard clock
pin 2 mouse data
pin 1 keyboard data
poi ho collegato un HD da 10GB 2.5" preso dal mio Toshiba Satellite 310CDS, che aveva su WinME.
Miracolo!
dopo un po di lavorio, è partito, ha installato un po' di drivers e un po' ne ho installati io, e alla fine ha funzionato.
Interessante che ha 2 chipset grafici, quello primario è il VIA CLE266, quello secondario è il Radeon 7000 series.
Allora, il CLE266 prende 32MB (da 16 fino a 64, selezionabili nel BIOS) dalla ram DDR, mentre il Radeon ha i suoi 32MB installati sulla scheda.
Il Radeon arriva a delle risoluzioni inimmaginabili! (almeno per me)
Non avendo ancora attuato un attacco per CDROM, ho provato a leggere il cd di WinXP Pro dal mio PC collegato in rete e a avviare l'installazione.
Perfetto, s'è installato WinXP senza problemi, trovando automaticamente i driver per la Radeon, mentre quelli audio e video del CLS266 li ho scaricati dal sito VIA.
Sono proprio soddisfatto. Adesso l'unico problema è creare un adattatore IDE 44pin che mi cambi il genere del connettore (sulla scheda c'è solo la femmina 44pin) in modo che possa collegarci un cavo 40 pin con un cdrom.
Contrariamente a quanto si potrebbe pensare, non basta mettere una serie di pin lunghi nella femmina, per cambiare il genere, ma questi pin devono essere anche scambiati di posto, l'1 col 2, il 3 col 4, e via così, altrimenti si brucia la periferica attaccata.
se non avete capito perchè, scrivetemi che ve lo spiego!

aggiornamento del 15-10-2009

ecco una foto della mia scheda come è ora, con adattatori autocostruiti, radiatori sui chip e CPU.

e qui vediamo l'header maschio IDE 44pin che ho saldato sul fondo della scheda, dove è saldato l'header femmina 44pin

grazie a Michele, che mi ha scritto, e dopo una lunga ricerca su internet, ho scoperto chi vende, o vendeva, queste schede, complete del loro case specifico. si tratta di www.pcgarantito.it.

Michele (non so il cognome) mi ha inviato alcune foto della sua scheda, uguale alla mia, della quale lui possiede anche il case originale:


da questa foto qui sotto si desume chiaramente che i due connettori passo IDE 40 pin sono evidentemente per una scheda figlia sulla quale inserire schede di espansione PCI , percè è in linea con la finestra rettangolare sul retro del case

aggiornamento dell'11-07-2015

eccomi di nuovo qui, con qualche timido sviluppo.

ho trovato una scatola di latta di biscotti Lazzaroni  nella quale inserire la scheda madre. le aperture sono un po' rozze, ma l'importante è inserirla e non avere più cavi in giro quando la testo.

c'è un piccolo problema di tastiera, che dopo un po' non va più, sia ps/2 che usb. potrebbe essere l'alimentazione, per ora alimento la scheda con un psu 5V 6A, penserei che 6A siano sufficienti, ma tornerò a provarla con un psu da pc AT